您现在的位置:程序化交易>> 期货公式>> 博易大师>> 博易大师知识>>正文内容

麻烦老师改个指标,谢谢! [博易POBO]

咨询内容:

麻烦老师改个指标,谢谢!

主图指标,不能用,麻烦老师改一下,谢谢!
 
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
MA120:=MA(CLOSE,120);
HIGHN:=10;
LOWN:=10;
HIGHDISPLAY:=0;
LOWDISPLAY:=0;
ZGDISPLAY:=0;
MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
//DRAWICON(CROSS(CC,0.5),H,'ICO156');
DDD:=BARSLAST(CC);
CURRBARSCOUNT:=DATACOUNT-BARPOS;
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);
{顶部}DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=REFX1(DINGBUTS,10000);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=REFX1(DINGBUTS1,10000);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高点压力:TRENDLINES(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H),RGB(0,255,64),DOT;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
//DRAWICON(CROSS(CC1,0.5),L,'ICO155');
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=REFX1(DDTS1,10000);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=REFX1(DDTS2,10000);
低点支撑:TRENDLINES(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L),COLORRED,DOT;
ZGSTAR:=(高点压力+低点支撑)/2;
ZGEND:=REFX1((高点压力+低点支撑)/2,10000);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
操盘线:EMA(EMA(C,10),10),RGB(255,0,128),LINETHICK3;
B:=操盘线>REF(操盘线,1);
IF(B-1,操盘线,NULL),RGB(0,128,255),LINETHICK3;
AAA:=EMA(C,5) > EMA(C,20);
BB:=EMA(C,5) < EMA(C,20);
CCA:= EMA(C,5) > EMA(C,10);
CC1A:=EMA(C,5) < EMA(C,10);
DD:=CLOSE<OPEN;


EMA(CLOSE,90),RGB(0,255,0),LINETHICK3;
DRAWCOLORLINE(EMA(C,90)>REF(EMA(C,90),1),EMA(C,90),COLORRED,RGB(0,255,0)),LINETHICK3;

EMA30:EMA(CLOSE,0);//定义30周期收盘价的指数平滑移动平均值。
TMP:=CLOSE-EMA2(CLOSE,30);
//PLAYSOUND(TMP>0.1&&REF(TMP<=0.1,1)||TMP<=0.1&&REF(TMP>0.1,1),'A');
DRAWLINE(TMP>0.1&&C<=O,LOW,TMP>0.1,HIGH,COLORRED);
DRAWLINE(TMP<=0.1&&C<=O,LOW,TMP<=0.1,HIGH,COLORGREEN);
STICKLINE(TMP>0&&C<=O,OPEN,CLOSE,COLORRED,0);
STICKLINE(TMP<=0&&C<=O,OPEN,CLOSE,COLORGREEN,0);
DRAWLINE(TMP>0.1&&C>=O,LOW,TMP>0.1,O,COLORRED);
DRAWLINE(TMP>0.1&&C>=O,H,TMP>0.1,C,COLORRED);
DRAWLINE(TMP<=0.1&&C>=O,LOW,TMP<=0.1,O,COLORGREEN);
DRAWLINE(TMP<=0.1&&C>=O,H,TMP<=0.1,C,COLORGREEN);
STICKLINE(TMP>0&&C>=O,OPEN,CLOSE,COLORRED,1);
STICKLINE(TMP<=0&&C>=O,OPEN,CLOSE,COLORGREEN,1);




 

 

 来源:程序化99网( WWW.龙8官方网站手机版.COM )

博易技术人员: 不少函数不匹配,此类公式无法修改 来源 程序化久久网

 

有思路,想编写各种指标公式,交易模型,选股公式,还原公式的朋友

可联系技术人员 QQ: 262069696  点击在线交流或微信号:cxh99cxh99  进行 有偿收费 编写!

怎么收费,代编流程等详情请点击阅读!

(注:由于人数限制,QQ或微信请选择方便的一个联系我们就行,加好友时请简单备注下您的需求,否则无法通过。谢谢您!)


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容