您现在的位置:程序化交易>> 期货公式>> 博易大师>> 博易大师知识>>正文内容

请老师加两条线 [博易POBO]

咨询内容:

请老师加两条线


QQ图片20190605193517.png
添加图中圆圈处的两条线

G:=MA(C,5);

D:=MA(C,10);

NNH:=BARSLAST(H=HHV(H,7)) ,NODRAW;

NNL:=BARSLAST(L=LLV(L,7)) ,NODRAW;

NN:=IF(REF(G,NNH)>REF(D,NNH) AND NNH<=4,NNH,IF(REF(G,NNL)<REF(D,NNL) AND NNL<=4,NNL,5)) ,NODRAW;

N00:=IF(ISLASTBAR AND NN>0,NN,5) ,NODRAW;

HH0:=REF(H,N00)=HHV(H,6);

LL0:=REF(L,N00)=LLV(L,6);

FG01:BACKSET(HH0,N00+1)>BACKSET(HH0,N00),NODRAW;

FD01:BACKSET(LL0,N00+1)>BACKSET(LL0,N00) ,NODRAW;

FG02:=FG01=FD01 AND G>D,NODRAW;

FD02:FG01=FD01 AND G<D,NODRAW;

TTTT:BARSLAST(FD01),NODRAW;

FG0:=FG01 AND IF(FG02=1,H=HHV(H,BARSLAST(REF(FD01,1))+1),H=HHV(H,IF(BARSLAST(L=LLV(L,7))>=5,5,BARSLAST(FD01)))) AND FD02=0 ,NODRAW;

FD0:=FD01 AND IF(FD02=1,L=LLV(L,BARSLAST(REF(FG01,1))+1),L=LLV(L,IF(BARSLAST(H=HHV(L,7))>=5,5,BARSLAST(FG01)))) AND FG02=0 ,NODRAW;

GT:BARSLAST(FG0),NODRAW;

DT:BARSLAST(FD0),NODRAW;

LLLL:DT=0 AND REF(DT,1)<GT AND L>REF(L,REF(DT,1)+1),NODRAW;

FG1:BACKSET(REFX(GT,1)=0 AND GT<DT AND REFX(H,1)>=REF(H,GT),GT+1),NODRAW;

FD1:BACKSET(REFX(DT,1)=0 AND DT<GT AND REFX(L,1)<=REF(L,DT),DT+1),NODRAW;

FG11:IF(GT=0 AND REF(GT,1)<DT AND IF(REF(G,BARSLAST(L=LLV(L,7)))>REF(D,BARSLAST(L=LLV(L,7))),BARSLAST(L=LLV(L,7))<5,1) AND H<REF(H,REF(GT,1)+1),1,0),NODRAW;

FD11:IF(DT=0 AND REF(DT,1)<GT AND IF(REF(G,BARSLAST(H=HHV(H,7)))<REF(D,BARSLAST(H=HHV(H,7))),BARSLAST(H=HHV(H,7))<5,1) AND L>REF(L,REF(DT,1)+1),1,0),NODRAW;

GT1:BARSLAST(FG11<>1 AND FG1<>1 AND FG0),NODRAW;

DT1:BARSLAST(FD11<>1 AND FD1<>1 AND FD0),NODRAW;

FD2:BACKSET(REFX(GT1,1)=0 AND DT1<3 AND GT1-DT1<4 AND REF(L,DT1)>LLV(L,GT1+5),DT1+1),NODRAW;

FG2A:BACKSET(REFX(GT1,1)=0 AND DT1<3 AND GT1-DT1<4 AND REF(L,DT1)<=LLV(L,GT1+5) AND REF(H,GT1)>HHV(H,GT1+5),GT1+1),NODRAW;

FG2B:IF(GT1=0 AND DT1<4 AND REF(GT1,1)-DT1<4 AND REF(L,DT1)<=LLV(L,REF(GT1,1)+6) AND H>HHV(H,REF(GT1,1)+6),1,0),NODRAW;

FG2:BACKSET(REFX(DT1,1)=0 AND GT1<3 AND DT1-GT1<4 AND REF(H,GT1)<HHV(H,DT1+5),GT1+1),NODRAW;

FD2A:BACKSET(REFX(DT1,1)=0 AND GT1<3 AND DT1-GT1<4 AND REF(H,GT1)>=HHV(L,DT1+5) AND REF(L,DT1)>LLV(L,DT1+5),DT1+1),NODRAW;

FD2B:IF(DT1=0 AND GT1<4 AND REF(DT1,1)-GT1<4 AND REF(H,GT1)>=HHV(H,REF(DT1,1)+6) AND L>LLV(L,REF(DT1,1)+6),1,0),NODRAW;

TTTTTT: H<REF(H,REF(GT1,1)+1) AND DT1<4,NODRAW;

HHHHHH:REF(LLV(L,10),DT1),NODRAW;

FG21:IF(GT1=0 AND DT1<4 AND H<=REF(H,REF(GT1,1)+1) ,1,0),NODRAW;

FD21:IF(DT1=0 AND GT1<4 AND L>=REF(L,REF(DT1,1)+1) ,1,0),NODRAW;

FD231:BACKSET(REFX(GT1,1)=0 AND DT1>3 AND GT1>DT1 AND GT1-DT1<4 AND REFX(H,1)>REF(H,GT1) AND REF(L,DT1)>REF(LLV(L,10),DT1),DT1+1),NODRAW;

FG23:BACKSET(REFX(GT1,1)=0 AND DT1>3 AND GT1>DT1 AND GT1-DT1<4 AND REFX(H,1)>REF(H,GT1) AND (REF(H,GT1)<REF(HHV(H,13),GT1) OR REF(FD231,DT1)=0),GT1+1),NODRAW;

FG231:BACKSET(REFX(DT1,1)=0 AND GT1>3 AND DT1>GT1 AND DT1-GT1<4 AND REFX(L,1)<REF(L,DT1) AND REF(H,GT1)<REF(HHV(H,10),GT1) ,GT1+1),NODRAW;

FD23:BACKSET(REFX(DT1,1)=0 AND GT1>3 AND DT1>GT1 AND DT1-GT1<4 AND REFX(L,1)<REF(L,DT1) AND ( REF(L,DT1)>REF(LLV(L,13),DT1) OR REF(FG231,GT1)=0),DT1+1),NODRAW;

FDD23:REF(H,GT1)<REF(HHV(H,10),GT1) OR REF(FD23,DT1)=0,NODRAW;

FD24:BACKSET(REFX(GT1,1)=0 AND DT1>3 AND GT1>DT1 AND GT1-DT1<4 AND REFX(H,1)<HHV(H,GT1+3) AND REF(L,DT1)>LLV(L,DT1+5),DT1+1),NODRAW;

FG24:BACKSET(REFX(DT1,1)=0 AND GT1>3 AND DT1>GT1 AND DT1-GT1<4 AND REFX(L,1)>LLV(L,DT1+3) AND REF(H,GT1)<HHV(H,GT1+5),GT1+1),NODRAW;

GT2:BARSLAST(FG21<>1 AND FG23<>1 AND FG231<>1 AND FG24<>1 AND FG2<>1 AND FG2A<>1 AND FG2B<>1 AND GT1=0),NODRAW;
DT2:BARSLAST(FD21<>1 AND FD23<>1 AND FD231<>1 AND FD24<>1 AND FD2<>1 AND FD2A<>1 AND FD2B<>1 AND DT1=0),NODRAW;

FG3:BACKSET(REFX(GT2,1)=0 AND GT2<DT2 AND REFX(H,1)>=REF(H,GT2),GT2+1),NODRAW;

FD3:BACKSET(REFX(DT2,1)=0 AND DT2<GT2 AND REFX(L,1)<=REF(L,DT2),DT2+1),NODRAW;

FG31:IF(GT2=0 AND REF(GT2,1)<DT2 AND H<REF(H,REF(GT2,1)+1),1,0),NODRAW;

FD31:IF(DT2=0 AND REF(DT2,1)<GT2 AND L>REF(L,REF(DT2,1)+1),1,0),NODRAW;

GT3:BARSLAST(GT2=0 AND FG3<>1 AND FG31<>1 ),NODRAW;

DT3:BARSLAST(DT2=0 AND FD3<>1 AND FD31<>1),NODRAW;

FG4:BACKSET(REFX(GT3,1)=0 AND GT3<DT3 AND REFX(H,1)>=REF(H,GT3),GT3+1),NODRAW;

FD4:BACKSET(REFX(DT3,1)=0 AND DT3<GT3 AND REFX(L,1)<=REF(L,DT3),DT3+1),NODRAW;

FG41:IF(GT3=0 AND REF(GT3,1)<DT3 AND H<REF(H,REF(GT3,1)+1),1,0),NODRAW;

FD41:IF(DT3=0 AND REF(DT3,1)<GT3 AND L>REF(L,REF(DT3,1)+1),1,0),NODRAW;

HHH:=GT3=0 AND FG31<>1 AND FG3<>1,NODRAW;

LLL:=DT3=0 AND FD31<>1 AND FD3<>1,NODRAW;
QQ:=BACKSET(ISLASTBAR,MAX(BARSLAST(HHH)+1,BARSLAST(LLL)+1));
DRAWLINE(HHH ,H,LLL,L,0),COLORGREEN,LINETHICK2;

DRAWLINE(LLL,L,HHH ,H,0),COLORRED,LINETHICK2;

DRAWSL(FG0 ,H,0,9,0),COLORFFCC00,CIRCLEDOT,LINETHICK5;

DRAWSL(FD0 ,L,0,9,0),COLORFFFFFF,CIRCLEDOT,LINETHICK5;

DRAWNUMBER(HHH,H,H,0),VALIGN2,COLORBLUE;

DRAWNUMBER(LLL,L,L,0),VALIGN0,COLORBLUE;

DRAWTEXT(HHH,L,'开空'),VALIGN2,COLORYELLOW;

DRAWTEXT(LLL,H,'开多'),VALIGN0,COLORYELLOW;



TT:=HHH||LLL;
TNN:=SUMBARS(TT,6);
TB:=BACKSET(ISLASTBAR,TNN);
TBN:=BARSLAST(CROSS(TB=1,0.5))+1;

DRAWLINE(HHH&&TB ,H,LLL&&TB,L,0),COLORYELLOW,LINETHICK3;
DRAWLINE(LLL&&TB,L,HHH&&TB ,H,0),COLORMAGENTA,LINETHICK3;

DRAWSL(FG0 &&TB ,H,0,1,0),COLORYELLOW,CIRCLEDOT,LINETHICK9;
DRAWSL(FD0 &&TB ,L,0,1,0),COLORFF0000,CIRCLEDOT,LINETHICK9;

DRAWNUMBER(HHH&&TB,H,IF(COUNT(TT,TBN)=5,DRAWNULL,COUNT(TT,TBN)),0),COLORMAGENTA,FONTSIZE27,VALIGN2;
DRAWNUMBER(LLL&&TB,L,IF(COUNT(TT,TBN)=6,DRAWNULL,COUNT(TT,TBN)),0),COLORYELLOW,FONTSIZE27,VALIGN0;


T01:VALUEWHEN(HHH&&TB&&COUNT(TT,TBN)=1,H),NODRAW,COLORMAGENTA,PRECIS0;
T02:VALUEWHEN(LLL&&TB&&COUNT(TT,TBN)=2,L),NODRAW,COLORYELLOW,PRECIS0;
T3:VALUEWHEN(HHH&&TB&&COUNT(TT,TBN)=3,H),NODRAW,COLORMAGENTA,PRECIS0;
T4:VALUEWHEN(LLL&&TB&&COUNT(TT,TBN)=4,L),NODRAW,COLORYELLOW,PRECIS0;
T5:VALUEWHEN(HHH&&TB&&COUNT(TT,TBN)=5,H),NODRAW,COLORMAGENTA,PRECIS0;
T6:VALUEWHEN(LLL&&TB&&COUNT(TT,TBN)=6,L),NODRAW,COLORYELLOW,PRECIS0;


S1:VALUEWHEN(LLL&&TB&&COUNT(TT,TBN)=1,L),NODRAW,COLORMAGENTA,PRECIS0;
S2:VALUEWHEN(HHH&&TB&&COUNT(TT,TBN)=2,H),NODRAW,COLORYELLOW,PRECIS0;
S3:VALUEWHEN(LLL&&TB&&COUNT(TT,TBN)=3,L),NODRAW,COLORMAGENTA,PRECIS0;
S4:VALUEWHEN(HHH&&TB&&COUNT(TT,TBN)=4,H),NODRAW,COLORYELLOW,PRECIS0;
S5:VALUEWHEN(LLL&&TB&&COUNT(TT,TBN)=5,L),NODRAW,COLORMAGENTA,PRECIS0;
S6:VALUEWHEN(HHH&&TB&&COUNT(TT,TBN)=6,H),NODRAW,COLORYELLOW,PRECIS0;
DRAWNUMBER(ISLASTBAR,REF(H,BARSLAST(HHH&&QQ)),REF(H,BARSLAST(HHH&&QQ)),2),COLORRED,ALIGN0;
DRAWNUMBER(ISLASTBAR,REF(L,BARSLAST(LLL&&QQ)),REF(L,BARSLAST(LLL&&QQ)),2),COLORGREEN,ALIGN0;

DRAWNUMBER(HHH&&TB&&COUNT(TT,TBN)>=2,(H+REF(L,SUMBARS(TT,2)-1))/2,(H+REF(L,SUMBARS(TT,2)-1))/2,2),COLORRED,ALIGN0;
DRAWNUMBER(LLL&&TB&&COUNT(TT,TBN)>=2,(L+REF(H,SUMBARS(TT,2)-1))/2,(L+REF(H,SUMBARS(TT,2)-1))/2,2),COLORGREEN,ALIGN0; <!-- 咨询内容:

附件 :

-->

 

 来源:程序化99网( WWW.龙8官方网站手机版.COM )

博易技术人员: 老师1,3连线与2画平行延长线 无法修改 来源 程序化久久网

 

有思路,想编写各种指标公式,交易模型,选股公式,还原公式的朋友

可联系技术人员 QQ: 262069696  点击在线交流或微信号:cxh99cxh99  进行 有偿收费 编写!

怎么收费,代编流程等详情请点击阅读!

(注:由于人数限制,QQ或微信请选择方便的一个联系我们就行,加好友时请简单备注下您的需求,否则无法通过。谢谢您!)


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容