您现在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文内容

操盘要点公式源码[大智慧公式]

相关标签:

 

原理解析:

V8赋值:600*(收盘价的3日指数移动平均-最低价的30日指数移动平均)/最低价的30日指数移动平均
V9赋值:V8的7日指数移动平均
VA赋值:(以120*收盘价/100元价格计算的获利盘比例-以100*收盘价/100元价格计算的获利盘比例)*100
VB赋值:(-100)*(以120*收盘价/100元价格计算的获利盘比例-以100*收盘价/100元价格计算的获利盘比例)+5
输出底买入: 如果VA+VB<7ANDCROSS(V8,V9)ANDV9<-18ANDV9<VB,返回60,否则返回50
VC赋值:(2*收盘价+最高价+最低价)/4
VD赋值:34日内最低价的最低值
VE赋值:34日内最高价的最高值
VF赋值:21日内最低价的最低值
V10赋值:21日内最高价的最高值
V11赋值:(VC-VF)/(V10-VD)*100的5日指数移动平均
V12赋值:(VC-VD)/(VE-VD)*100的8日指数移动平均
输出X:V11,画白色
输出顶区:V12
当满足条件V11-V12+20>=20时,在V11-V12+20和20位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORF000FF
V13赋值:V12的5日指数移动平均
当满足条件V12>0AND(V12-V13)>=0时,在80和78位置之间画柱状线,宽度为6,0不为0则画空心柱.,画红色
当满足条件V12>0AND(V12-V13)<0时,在80和78位置之间画柱状线,宽度为6,1不为0则画空心柱.,画蓝色
当满足条件V12>0AND(V12-V13)>=0时,在20和18位置之间画柱状线,宽度为6,0不为0则画空心柱.,画红色
当满足条件V12>0AND(V12-V13)<0时,在20和18位置之间画柱状线,宽度为6,1不为0则画空心柱.,画蓝色
当满足条件V12>V13时,在V12和V13位置之间画柱状线,宽度为15,1不为0则画空心柱.,画绿色
0
 

 

源码:

 


V8:=600*(EMA(C,3)-EMA(L,30))/EMA(L,30);
V9:=EMA(V8,7);
VA:=(WINNER(120*C/100)-WINNER(100*C/100))*100;
VB:=(-100)*(WINNER(120*C/100)-WINNER(100*C/100))+5;
底买入: IF(VA+VB< 7 AND CROSS(V8,V9) AND V9< -18 AND V9< VB,60,50);
VC:=(2*C+H+L)/4;
VD:=LLV(L,34);
VE:=HHV(H,34);
VF:=LLV(L,21);
V10:=HHV(H,21);
V11:=EMA((VC-VF)/(V10-VD)*100,5);
V12:=EMA((VC-VD)/(VE-VD)*100,8);
X:V11,colorwhite;
顶区:V12;
STICKLINE(V11-V12+20>=20 ,V11-V12+20 ,20 ,5 ,0 ),COLORF000FF;
V13:=EMA(V12,5);
STICKLINE(V12>0 AND (V12-V13)>=0 ,80 ,78 ,6 ,0 ),COLORRED;
STICKLINE(V12>0 AND (V12-V13)<0 ,80 ,78 ,6 ,1 ),COLORBLUE;
STICKLINE(V12>0 AND (V12-V13)>=0 ,20 ,18 ,6 ,0 ),COLORRED;
STICKLINE(V12>0 AND (V12-V13)<0 ,20 ,18 ,6 ,1 ),COLORBLUE;
STICKLINE(V12>V13 , V12,V13,15 ,1 ),COLORGREEN;{}
0;

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,交易模型,选股公式,还原公式的朋友

可联系技术人员 QQ: 262069696  点击在线交流或微信:cxhjy888 进行 有偿收费 编写!(注:由于人数限制,QQ或微信请选择方便的一个联系我们就行,加好友时请简单备注下您的需求,否则无法通过。谢谢您!)

怎么收费,代编流程等详情请点击查阅!

(注:由于人数限制,QQ或微信请选择方便的一个联系我们就行,加好友时请简单备注下您的需求,否则无法通过。谢谢您!)

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容